워드프레스 4.9.x 버전 업데이트 주의보

워드프레스-업데이트-4-9-4-주의-에러-경고

최근 워드프레스 4.9.x 버전 ( 4.9.0 ~ 4.9.4 ) 코어의 버그로 인해 다양한 에러가 접수되고 있어서 워드프레스 업데이트 진행에 주의를 해야합니다. 이 버그는 언어 파일과 관련되어 있는 경우가 많은데, 기존의 번역 파일 들과 충돌을 일으켜서 다양한 에러 및 경고 메시지가 나오고 있습니다. 기능상으로는 크게 영향을 미치지 않고 있지만, 경고문구가 관리자화면 뿐만 아니라 고객들이 보는 프론트엔드 화면에서도 나타나고 있기 때문에 이로 인한 소비자 신뢰 저하 및 보안 악화가 예상이 됩니다. 그렇기 때문에 4.9.x 이상 버전으로 업데이트를 할때는 충분히 검토하거나 전문가와 상의 후 진행을 하시는 것이 필요합니다.

 1. 워드프레스 업데이트 후 우커머스 경고 문구 증상 ( Woocommerce )

우커머스를 사용하는 경우 워드프레스 업데이트  후 갑자기 아래와 같은 경고 메시지가 나오는 경우가 발생하고 있습니다.

Warning: sprintf(): Too few arguments gateways/paypal/class-wc-gateway-paypal

Warning: sprintf(): Too few arguments in wp-content/plugins/woocommerce/includes/gateways/paypal/class-wc-gateway-paypal.php on line 37

Warning: sprintf(): Too few arguments in wc-admin-help.php on line 208

Warning: sprintf(): Too few arguments in /www/domains/wp-content/plugins/woocommerce/includes/gateways/paypal/includes/settings-paypal.php on line 126

sprintf 함수의 인수의 갯수가 달라서 생기는 경고인데, 번역파일 ( .mo, .po ) 파일에서 인수의 갯수가 달라지는 경우 위와 같은 경고가 발생하고 있습니다.

단순히 번역파일을 수정해 주면 경고 문구가 사라지기는 하지만 워드프레스 버그가 패치된 버전이 나오면 업데이트를 해주어야 합니다.

 

2. 아바다 퓨전 빌더 ( Avada Fusion Builder ) 작동 이상 

국내에서 가장 많이 이용되고 있는 아바다 테마의 퓨전 빌더와 테마의 작동에 문제가 생기는 증상이 많이 접수되고 있습니다. 제가 증상을 살펴본 결과 여러가지 충돌 문제가 생기는 것으로 보입니다. 제작사 쪽에서 몇가지 원인에 대한 솔루션은 제공하고 있지만, 완벽한 답변이나 패치를 내놓지 않고 있기 때문에, 새로운 버전이 나올때까지 기다린 다음 업데이트를 해야될것 같습니다. 아래는 언어 파일에 대한 버그를 설명하고 있는 내용입니다. 추후 증상의 원인을 살펴보고 업데이트 되는 내용이 있으면 공유하겠습니다.

SOLUTION: This is a confirmed WordPress core bug involving language files: https://core.trac.wordpress.org/ticket/42574. “MediaElement upgrade causing JS errors when certain languages are in use e.g de_DE-formal”.

The issue applies to any language file in this format: de_DE-formal. To resolve this, change the WordPress Core to the regular format: de_DE by changing the language in the WordPress admin area (Settings > General). For example, if currently set to “Deutsch (Sie)” instead select “Deutsch”.

( 아바다 제작사 오류 관련 페이지 )

위와 같이 영어 외의 사이트는 언어로 인한 버그로 사이트가 정상적으로 작동이 안될수 있는 위험이 있기 때문에, 워드프레스 4.9.x 버전으로 업데이트는 조심해서 진행하셔야 합니다.

 

4.9.x 버전으로 업데이트를 한후 문제가 생겼거나  업데이트가 필요한 분들은 워드프레스 업데이트 작업 및 오류 해결 작업을 도와드리고 있으니 문의 주시면 성심껏 상담해 드리겠습니다.

 

Write a comment