레이어 슬라이더 버전으로 인한 아바다 퓨전빌더 , 맥스 메가 메뉴 작동 이상

레이어슬라이더 아바다 퓨전빌더 맥스메가메뉴 작동이상

아바다의 페이지 빌더인 퓨전빌더 ( Fusion Builder ) 와 맥스 메가 메뉴 ( Max Mega Menu ) 가 제대로 작동이 되지 않는 증상이 있어 수정 의뢰가 들어왔습니다.
얼마전까지만 해도 제대로 작동을 했었는데 갑자기 안된다고 하셨는데, 이런 경우는 대부분 플러그인의 버전 차이로 인한 충돌 가능성이 가장 높습니다.

증상을 살펴보니 글과 페이지 편집화면에서 퓨전빌더가 전혀 작동이 안되고, 메뉴 수정 화면에서 마우스 클릭이 작동하지 않았습니다.
개발자 도구의 콘솔을 확인하니 자바스크립트의 충돌 현상이 보여서 설치되어 있는 플러그인을 전부 비활성화 시킨다음,
하나씩 활성화 시키면서 원인이 되는 플러그인을 찾아보았습니다.
결국 레이어 슬라이더가 문제라는 것을 알아낼 수 있었고, 버전을 6.6.8 에서 최신버전인 6.7 로 업데이트 하였습니다.

업데이트를 하니 아바다 퓨전빌더는 제대로 작동을 하는데, 맥스 메가 메뉴는 여전히 문제 현상을 보였습니다.
그래서 레이어 슬라이더의 고급 설정 화면에서 [Trouble Shooting] 부분의 옵션을 조정해 주니
모든 문제가 사라지고  관리자 화면이 정상적으로 작동을 하게 되었습니다.

유료 테마를 사용하다보면 워드프레스 사이트가 자동 업데이크가 되도록 설정이 되어있는 경우
워드프레스 코어는 자동으로 업데이트가 되고,  테마, 무료 플러그인들은 업데이트 메뉴에서 업데이트 알림이 나타나면 쉽게 업데이트를 할수 있습니다.
그런데 유료테마에서 번들로 제공되는 레이어슬라이더, 레볼루션 슬라이더, 비주얼 컴포저 같은 유료 플러그인들은
수동으로 업데이트를 해주어야 하는 경우가 많습니다.
그러지 않았을 경우 버전 차이로 인해 충돌 현상이 나타 나거나 갑자기 사이트가 제대로 작동을 하지 않을 수 있습니다.

워드프레스는 짧게는 1~2개월, 길게는 6개월에 한번은 업데이트가 진행이 되니
이 점 유의해서 관리하시면 좋을꺼 같습니다.
혹 잘 작동을 하다가 문제가 생기는 경우가 있으시면 편하게 스마일보이랩과 상담 해주세요.

Write a comment